Account Upgrade Processing Delay

Incident Report for Metal Pay

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 15:36 PDT

Investigating

We're currently experiencing delays in account upgrade processes due to a global internet outage affecting our systems. Our team is actively monitoring the situation and working to restore full functionality.

Thanks for your patience and understanding while we navigate this disruption.
Posted Oct 20, 2025 - 13:34 PDT
This incident affected: Metal Pay Application (Metal Pay (iOS), Metal Pay (Android)).